Gallery doesn't work in Chrome

voodoo's Avatar

voodoo

07 Jan, 2013 09:13 PM

Hello,

The gallery thumbnails don't work in Chrome:
http://dimsemenov.com/plugins/royal-slider/gallery-vertical-fade/

I get the same issues on my local install.

How do I fix this?

  1. Support Staff 1 Posted by Dmitry Semenov on 08 Jan, 2013 06:47 AM

    Dmitry Semenov's Avatar

    Hello,

    What exactly version of Chrome and what exactly version of OS? Do you have any specific devices - like trackpad or sylus connected? Have you tried turning off all browser extensions?

    Dmitry

  2. 2 Posted by voodoo on 08 Jan, 2013 03:54 PM

    voodoo's Avatar

    Chrome: No extensions installed. Windows 7. No trackpad or stylus.
    Version 23.0.1271.97 m

  3. 3 Posted by voodoo on 08 Jan, 2013 04:00 PM

    voodoo's Avatar

    NOTE: The things you are mentioning are fairly common, so I don't know that I really want to tell customers using Chrome to turn off their extensions, trackpad and stylus so the slider works.

  4. 4 Posted by voodoo on 08 Jan, 2013 05:26 PM

    voodoo's Avatar

    Ok, I just had 3 other people check with Chrome. All can reproduce this bug.

  5. Support Staff 5 Posted by Dmitry Semenov on 08 Jan, 2013 06:06 PM

    Dmitry Semenov's Avatar

    Please record the screencast with this page http://dimsemenov.com/plugins/royal-slider/gallery-vertical-fade/ , just like this one - http://www.youtube.com/watch?v=oMZX9zglQAk&feature=youtu.be

    You may use http://screenr.com to record video.

    I'm just saying that RoyalSlider plugin is popular, and if there was such issue with Chrome on Windows, I'd had a lot of threads and emails here about this. So please try to figure out what might be different in your case.

    Dmitry

  6. 6 Posted by tom on 17 Jan, 2013 03:30 AM

    tom's Avatar

    Hi - I have exactly the same problem on Chrome - same test page too.

    It works perfectly on ie (all versions as far as I can tell) and also fine on firefox, but on Chrome, I cannot click on any of the thumbnails.

    When I click on the main screen, the slider advances correctly - also I noticed if I go full screen, the thumbnails start to work again - but inside normal browser window, they are just not clickable. My version of chrome is Version 25.0.1364.36 beta-m - please not that I know this is a beta version of chrome, but I was having the same problem on the main non-beta current version of of chrome and upgraded to the beta to see if it would fix it - it didn't. I also have Windows 8, no extensions other than Google Dictionary.

    Thanks

  7. Support Staff 7 Posted by Dmitry Semenov on 17 Jan, 2013 02:01 PM

    Dmitry Semenov's Avatar

    @Tom Thank you.

    • do you have any js errors in Chrome console?
    • can you drag thumbnails?
    • Inspect thumbnails container and take a look if there isn't anything overlayed over them
    • Run this code in Chrome js console - jQuery('.royalSlider').on('click', '.rsNav', function() { console.log('clicked'); }); and take a look if "clicked" text is now printed when you click on thumbnails.
    • Can you repeat issue on example here http://dimsemenov.com/plugins/royal-slider/gallery-vertical-fade/ or just on your site?

    Dmitry

  8. 8 Posted by tom on 17 Jan, 2013 03:54 PM

    tom's Avatar

    Hi Dmitry,

    I did the above and recorded a screencast so you can see the results:

    http://www.screenr.com/UwR7

    Let me know how else I can help you test/resolve this issue.

    PS: I disabled all extensions in Chrome, just to be sure.

    Thanks

    Tom

  9. Support Staff 9 Posted by Dmitry Semenov on 18 Jan, 2013 02:07 PM

    Dmitry Semenov's Avatar

    Damn that's weird, I just asked all my firneds to check it and neither of them can repeat this. I also opened it in all version of Chrome on different platforms using browserstack.com and there are no issues there too.

    If you have a minute, please visit this page http://dimsemenov.com/plugins/royal-slider/win8test/ and tell what's printed in JS console when you click on thumbnail, I added some debugging logs -

    Thanks!

  10. 10 Posted by tom on 18 Jan, 2013 02:19 PM

    tom's Avatar

    Hi again!

    So I'm not sure if this will help or not, but when I DOUBLE clicked on the thumbnails, the following js error was returned (screenshot). I'm not sure if this is related or not?

    Otherwise, just let me know exactly what testing you need me to do on the test version you uploaded and I'll certainly do it!

    Thanks :)

    Tom

  11. Support Staff 11 Posted by Dmitry Semenov on 18 Jan, 2013 03:07 PM

    Dmitry Semenov's Avatar
  12. 12 Posted by tom on 18 Jan, 2013 03:10 PM

    tom's Avatar

    Hi - yes you're correct (unfortunately) - the js error goes away when I disable Google Dictionary, but sadly the problem itself remains, so we're no closer to finding the issue..... :(

    Let me know what testing I can do on that page and I will certainly do it.

    Thanks

    Tom

  13. Support Staff 13 Posted by Dmitry Semenov on 18 Jan, 2013 03:11 PM

    Dmitry Semenov's Avatar

    I added some more debugging code, please click on thumbnail again and tell me what it prints in console.

    Thank you.

  14. 14 Posted by tzvetan on 30 Jan, 2018 01:25 PM

    tzvetan's Avatar

    Hello Dmitri,

    I see that this subject is five years old, but I have exactly the same problem here: fading effect is not working in Chrome.
    When I try to use this slider http://dimsemenov.com/plugins/royal-slider/gallery-vertical-fade/ I can only see the first slide. When I click on another one, I just get a black screen (see attached).
    I'm on Mac OS 10.13, fresh install, Chrome 63.0.3239.132, no extensions.
    It works great with Safari and Firefox.
    Has a fix been released for this bug?

    Thanks in advance.
    Best,
    Tzvetan

  15. 15 Posted by tzvetan on 30 Jan, 2018 02:17 PM

    tzvetan's Avatar

    Seems like attached file didn't come up..

  16. Support Staff 16 Posted by Dmitry Semenov on 30 Jan, 2018 03:42 PM

    Dmitry Semenov's Avatar

    @Tzvetan , Hello, for some reason I can not reproduce the issue that you're describing, I tried on two OS X machines. What exactly do you do to switch slide? Simple click on the second thumbnail?

    Try adding style:

    .rsImg {
      will-change: opacity;
    }
    
  17. 17 Posted by tzvetan on 30 Jan, 2018 04:05 PM

    tzvetan's Avatar

    Thanks Dmitri for your reply.
    Unfortunately, it doesn't change anything.
    I get the same problem here whether I click on the main image or a thumbnail:
    http://dimsemenov.com/plugins/royal-slider/gallery-with-deeplinking/

    That's really weird that you don't get the same result than me and the other people up in the post.
    I use version 9.5.7 of your plugin. Is it the last one?
    My client wants to change this slideshow to another one with zoom in effect on each slide, so I don't have other option than changing "move" to "fade" transition:
    https://www.espaces-atypiques.com/paris/

    Thanks again for your support.

  18. Support Staff 18 Posted by Dmitry Semenov on 30 Jan, 2018 05:21 PM

    Dmitry Semenov's Avatar

    That's really weird that you don't get the same result than me and the other people up in the post.

    Pretty sure your issue is unrelated to others in this post, it was fixed a long time ago and it's a bit different.

    Can you please send me a screenshot of DOM tree in Chrome dev tools? When you get a blank slide - right click on it -> click "Inspect" and get a screenshot of "Elements" tab.

  19. 19 Posted by tzvetan on 30 Jan, 2018 05:28 PM

    tzvetan's Avatar

    That's a good check!
    As you can see on the screenshot, the opacity value doesn't turn to "1" and stays on "0".
    I have clicked on the second slide prior to DOM inspection.

  20. Support Staff 20 Posted by Dmitry Semenov on 30 Jan, 2018 06:21 PM

    Dmitry Semenov's Avatar
    • Try adding fadeinLoadedSlide:false and let me know if it helps.
    • Try adding allowCSS3:false, performance difference for fade transition is insignificant for it. Very strange that I cant reproduce the issue on my side...
  21. 21 Posted by tzvetan on 31 Jan, 2018 09:10 AM

    tzvetan's Avatar

    Hi Dmitri,

    Thanks for your support.
    It doesn't help... But I've tried on another computer this morning and it works on it. I've also asked my client if he sees the transition correctly on your site and he does.
    So there should be something wrong on my side, but that's strange, Mac OS and all my apps have been freshly installed last week.

    Could you please confirm that the fade transition is ok for you on my website with Chrome?
    https://www.espaces-atypiques.com/paris/

    Thanks!
    Best,
    Tzvetan

  22. Support Staff 22 Posted by Dmitry Semenov on 31 Jan, 2018 04:35 PM

    Dmitry Semenov's Avatar

    @Tzvetan, yes, it works on my side. Try testing in incognito mode.

  23. 23 Posted by tzvetan on 31 Jan, 2018 05:20 PM

    tzvetan's Avatar

    Thanks for your feedback. I always use incognito mode.
    Anyway, I will develop with Firefox.

    I'm now trying to add zoom effect. It works (it's online) but not always for the first slide. When the image takes a little time to load, there is no zoom.
    I've seen another post on the subject, but I thought addActiveClass would work all the time.

    Thanks again for your support.
    Tzvetan

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac