Google Chrome: Only the first YouTube video works

ben.glancy1's Avatar

ben.glancy1

21 Sep, 2012 08:32 PM

I'm having an issue here with a very simple page. I have two YouTube videos output like the below

<div class="royalSlider rsDefault">
<img class="rsImg" src="https://i.ytimg.com/vi/VxGMqKCcN6A/hqdefault.jpg" data-rsVideo="http://www.youtube.com/watch?v=VxGMqKCcN6A" /><img class="rsImg" src="https://i.ytimg.com/vi/-ZuowNcuGsc/hqdefault.jpg" data-rsVideo="http://www.youtube.com/watch?v=-ZuowNcuGsc" />
</div>

then the script is done like this:
 var test = $(".royalSlider").royalSlider({
keyboardNavEnabled: true,
fullscreen: {
enabled: true,
native: true
}
});

It's very simple, except in Google Chrome (UBUNTU Version 21.0.1180.81), when you click the full screen button the royal slider full screen and click play on any YouTube video after the first one, it just shows a black rectangle. The first ones works ok. And they all work ok when not in full screen mode.

Does anyone know why? I have enclosed the exact source code which is a php file.

  1. 1 Posted by ben.glancy1 on 22 Sep, 2012 06:43 PM

    ben.glancy1's Avatar

    This problem is down to when RoyalSlider is full screen. The youtube and vimeo are generally glitchy and dont play on my Android phone either, when Royal slider is in full screen.

    I notice there are not any RoyalSlider examples of full screen RoyalSlider video thumbnails. Makes sense

  2. ben.glancy1 closed this discussion on 22 Sep, 2012 07:43 PM.

  3. ben.glancy1 re-opened this discussion on 27 Sep, 2012 08:53 PM

  4. 2 Posted by ben.glancy1 on 27 Sep, 2012 08:55 PM

    ben.glancy1's Avatar

    I want to apologise for my earlier post about no support etc since you replied to my other one, been a bit of a frustrating day and I vented on here, very schoolboy and I'm sorry (think Nick Clegg).

    Anyway, there is a problem with Royal Slider with JQuery 1.8.0 are you aware:
    The proof is:

    I think I worked out that JQuery 1.8.0 was breaking the Royal Slider implementation

    I went back to 1.7.2 and it was working

    Proof:

    https://www.thepageuk.com/res/html/vppmedia_gallery.php

    against:

    http://dimsemenov.com/plugins/royal-slider/video-gallery/

    YOu have to go to the third vimeo and onwards and it goes black in Google Chrome but in your 1.7.2 one it doesn't. This was what was driving me up the wall. I expected JQuery to be backwards compatible.

    I'll leave these two here if you want to see

  5. Support Staff 3 Posted by Dmitry Semenov on 28 Sep, 2012 06:13 AM

    Dmitry Semenov's Avatar

    Hi,

    I'm sorry too, that I somehow completely missed your message, probably because discussion was closed before I even read it. Please allow up to 24h.

    Anyway, for some reason if I click play on third vimeo slide here - https://www.thepageuk.com/res/html/vppmedia_gallery.php in Google Chrome it workss fine, I tried like a 10 times. Am I missing something? Chrome 22, Mac.

    Slider doesn't touch API of players, it simply adds their iframe markup to display list when play button is clicked.

    You may update jQuery to 1.8.2 as they fixed many small bugs since 1.8.0.

    Dmitry

  6. 4 Posted by ben.glancy1 on 28 Sep, 2012 11:44 AM

    ben.glancy1's Avatar

    Hi, I think it's to do with my machine, I have Ubuntu Google Chrome.
    My friend also says it works for him on Chrome, which matches what you say.

    The 1.7.2 works but 1.8.0 doesn't for me. Just the third video along onwards... the first two usually seem to work. I will give 1.8.2 a shot.

    The Royal Slider is a lovely bit of kit really,  we are about to launch www.thepageuk.com with a facelift and a variety of new features, and one of the features for use is gonna use Royal Slider for the actors media so that they can email a casting director a url to view their work experience on any device. Agents have asked for something like this as as well to showcase their actors. We already have about a thousand actors with media and data so it should slot right in nicely.

    I'll send you an example when it goes live and hopefully we can stay in touch

    Thanks a lot and apologies again.

    ________________________________
     From: Dmitry Semenov <[email blocked]>
    To: [email blocked]
    Sent: Friday, 28 September 2012, 7:13
    Subject: Re: Google Chrome: Only the first YouTube video works [RoyalSlider HTML version issues #435]

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • mysource.html 3.51 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac