Manual slide do not continue with autoPlay

nenad.dvl's Avatar

nenad.dvl

04 Oct, 2012 01:19 PM

So I have this problem and I am not sure if it's usual or not.

autoPlay is enabled and it works really great. However, if I click to manually slide to an image the autoPlay option doesn't continue working after. It require page reload. I am not sure why is that but I hope it's an small issue that is possible to fix.

Here's my royalSlider script config with options:

<script>
    jQuery(document).ready(function($) {
        $(".royalSlider").royalSlider({
            keyboardNavEnabled: true,
            imageScaleMode: "fill",
            loopRewind: true,
            transitionType: "fade",
            video: {
                youTubeCode: '<iframe src="http://www.youtube.com/embed/%id%?&controls=0&rel=0&showinfo=0&autoplay=1" frameborder="no"></iframe>'
            },
            autoPlay: {
                enabled: true,
                pauseOnHover: true,
                delay: 4000
            }
        });
    });
</script>
  1. Support Staff 1 Posted by Dmitry Semenov on 04 Oct, 2012 01:52 PM

    Dmitry Semenov's Avatar

    Hi,

    You're probably looking for stopAtAction option - http://dimsemenov.com/plugins/royal-slider/documentation/#autoplay

    Dmitry

  2. 2 Posted by nenad.dvl on 04 Oct, 2012 02:05 PM

    nenad.dvl's Avatar

    Oops :]

    My bad... I havent seen such a option. Works fine now. Thank you Dmitry.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac