Internet Explorer 11 Problems

muhsin.cinar's Avatar

muhsin.cinar

15 Mar, 2018 03:59 PM

Hi,

we use royalslider as Image-Slider on our Homepage: https://www.frohberg.de/

In Internet Explorer 11, the plugin does not work. Only the first picture is displayed. The navigation arrows (left + right) and the bullets are invisible.

We use version 9.5.7 of the plugin.
$('#bannerSlider:not(.hasroyalSlider)').royalSlider({
        autoHeight: false,
        arrowsNav: true,
        controlNavigation: 'bullets',
        fadeinLoadedSlide: true,
        imageScaleMode: 'fit',
        imageAlignCenter: false,
        loop: true,
        loopRewind: true,
        numImagesToPreload: 6,
        keyboardNavEnabled: false,
        usePreloader: true,
        autoScaleSlider: true,
        autoScaleSliderHeight: 149,
        fitInViewport: true,
        autoPlay: {
            enabled: true,
            pauseOnHover: true,
            delay: 6000
        },
        sliderDrag: false
    }).addClass('hasroyalSlider');

Below is the initialization:

The plugin should actually be IE11 compatible. That's why I'm surprised by the problem. Could you please give us a solution.

  1. Support Staff 1 Posted by Dmitry Semenov on 15 Mar, 2018 05:46 PM

    Dmitry Semenov's Avatar

    Hello,

    There is a mistake in custom CSS that you added, visibility:unset is not supported by IE11 so it falls back to "hidden". Attached screenshot.

    Dmitry

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • RoyalSlider-Chrome64-NoProblem.png 214 KB
  • RoyalSlider-IE11-Problem.png 3.62 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac