visibleNearby is not working at all

geverem's Avatar


11 Dec, 2018 12:37 AM

Here is an example of a slider that supposes to show the images on the sides... but the images don't show up at all...

Where is my issue and can it be fixed?


  1. Support Staff 1 Posted by Dmitry Semenov on 11 Dec, 2018 06:44 AM

    Dmitry Semenov's Avatar


    You have visibleNearby.centerArea option set to 1, if you want to reduce the size of the current slide - set option to a lower value, for example to 0.5.

  2. 2 Posted by geverem on 11 Dec, 2018 05:00 PM

    geverem's Avatar

    When I do so and resize the window... the image shrinks with the page resize and I'm seeing black background on top and bottom...

    How can I avoid it?

    I want the first image to stay as big as the height of the DIV.


  3. Support Staff 3 Posted by Dmitry Semenov on 11 Dec, 2018 05:12 PM

    Dmitry Semenov's Avatar

    Please refer to on how to control image scaling.

    You may also use this technique if you want fixed width for center slide

  4. 4 Posted by geverem on 11 Dec, 2018 07:12 PM

    geverem's Avatar

    None of those things worked for me.

    They're all having issues.

    Can you be more specific?


  5. Support Staff 5 Posted by Dmitry Semenov on 11 Dec, 2018 07:51 PM

    Dmitry Semenov's Avatar

    Adjust autoScaleSlider options to modify slider height, as described here Note that it controls size of the whole slider, not center slide.

    If you want autoScaleSlider to control size only of the center slide, use the technique

    Hope it helps a bit more...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac