Failing to start transitions or stopping randomly on both the Fade and Slide options

mark.adams's Avatar

mark.adams

16 Mar, 2020 09:45 AM

I'm testing with full HD images (1920x1080 pixels) on a full HD LCD screen. All the images have been sized to 1920x1080 on the disk, before being added to the playlist. Generally finding that about 2 times out of 10 that the transitions fail to start, so just left with the first image on screen. Sometime it will play fine for 20 minutes or so, and then freeze on a slide, and also sometime slides stay on screen twice as long as they are set to. Using IE 11 on the latest builds of Windows 10 to display. I use other jQuery based components in the same way, and don't have the same issues with starting or freezing, so I think there is an issue with your code somewhere.
As soon as I can get this working, I will be buying your extended licence.
Thanks, Mark.

  1. Support Staff 1 Posted by Dmitry Semenov on 17 Mar, 2020 08:37 AM

    Dmitry Semenov's Avatar

    Hello,

    Can you please link to the page with the issue?

  2. 2 Posted by mark.adams on 27 May, 2020 11:17 AM

    mark.adams's Avatar

    Hi Dmitry. Sorry for the delay. We haven't been working on this since the Covid-19 lockdown here in the UK. I have attached a ZIP file on what we are doing. If you can unzip into a c:\SLIDER01 folder and take a look at the code. You need to preview with Internet Explorer on Windows 10. Not seen any issues whilst getting this ready this morning though. Thanks, Mark.

  3. Support Staff 3 Posted by Dmitry Semenov on 27 May, 2020 11:52 AM

    Dmitry Semenov's Avatar

    Hello,

    Slides must have non-trasparent background if you're using custom markup.

    Also consider using lazy-loading markup for images https://dimsemenov.com/plugins/royal-slider/documentation/#images

  4. 4 Posted by mark.adams on 27 May, 2020 12:06 PM

    mark.adams's Avatar

    Thanks.

    No transparent backgrounds used.

    Altering the playlist code from:

    <div>
    <img src="P001-Picture01-J001RW1920H1080.jpg" />
    </div>

    to:

    <div>
    <img class="rsImg" src="P001-Picture01-J001RW1920H1080.jpg" />
    </div>

    which will preload all the images?

    Can you just check the code above to make sure I am doing it right please.

    Thanks for your quick response,

    Regards

    Mark.

  5. Support Staff 5 Posted by Dmitry Semenov on 27 May, 2020 12:24 PM

    Dmitry Semenov's Avatar

    For a single image you need just:

    <a class="rsImg" href="path-to-image.jpg">image description</a>
    

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac