Issues with text not displaying or "flashing" onto screen on Chrome/Mac (21.0.1180.82)

Michael Pasqualone's Avatar

Michael Pasqualone

23 Aug, 2012 05:16 AM

Hi guys,

We're using the slider on our Australian website on our home-page: http://www.totalserve.net.au/ and having a noticing a few issues with Chrome for Mac.

With the first slide, "Free Web Hosting" the text to the right appears correctly, however if you leave your cursor somewhere off the slider and let the slider do it's thing you'll notice that the "Switch to Mac Deal" and "Exchange 2010" text in the slides seem to be 99% blocked. Moving the cursor over the slides then brings the text into view.

Any ideas?

Thanks!
Michael

  1. Support Staff 1 Posted by Dmitry Semenov on 23 Aug, 2012 05:25 AM

    Dmitry Semenov's Avatar

    Hi,

    This is well-known Chrome bug. If you put absolutely-positioned element without hardware acceleration inside container with hardware acceleration, it'll behave weird.

    To enable hardware acceleration on element add rsAbsoluteEl class to it or these CSS props:

    .slideText {
        -webkit-backface-visibility:hidden;
        -webkit-transform:translateZ(0);
    }
    

    Dmitry

  2. 2 Posted by Michael Pasqual... on 23 Aug, 2012 05:27 AM

    Michael Pasqualone's Avatar

    Is there an alternative way to position the text elements? I don't like the thought of having to enable hardware acceleration to display a block of text.

  3. Support Staff 3 Posted by Dmitry Semenov on 23 Aug, 2012 05:30 AM

    Dmitry Semenov's Avatar

    Don't worry, it doesn't affect performance or memory. It's already enabled, but on parent.

    Dmitry

  4. 4 Posted by Michael Pasqual... on 23 Aug, 2012 05:32 AM

    Michael Pasqualone's Avatar

    Cheers Dmitry, much appreciated! That's done the trick nicely.

  5. Dmitry Semenov closed this discussion on 23 Aug, 2012 05:34 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac