captions not showing on mobile.

proberts122's Avatar

proberts122

17 Nov, 2017 10:06 PM

Hi! We're still using this plugin and really like it. Unfortunately, the image captions are not showing properly on mobile on most images. On many images, they don't show at all. On some images, they are on top of the image instead of above it.

https://www.carynfriedlander.com/selected-works/natural-resources/
https://www.carynfriedlander.com/selected-works/hands/
https://www.carynfriedlander.com/selected-works/archive/

Please let me know if you would like WP log in credentials.

Thanks!

  1. Support Staff 1 Posted by Dmitry Semenov on 18 Nov, 2017 06:42 AM

    Dmitry Semenov's Avatar

    Hello,

    You may use relative units in slide markup editors like percents or ems, or add CSS that would align all captions on mobile in a specific way, for example:

    @media (max-width: 800px) {
      .rsSBlock {
         width: 100% !important;
         height: auto !important;
         left: 0 !important;
         top: auto !important;
         bottom: 0 !important;
      }
    }
    

    (CSS may be added to your theme style.css)

  2. 2 Posted by proberts122 on 08 Dec, 2017 07:19 PM

    proberts122's Avatar

    Is there a way to export the images from each gallery?  Or find them in
    a folder on the server?  I'm not seeing a specific folder. Thanks!

  3. Support Staff 3 Posted by Dmitry Semenov on 09 Dec, 2017 06:38 AM

    Dmitry Semenov's Avatar

    No, there isn't such option. If you're making many image-based sliders, consider overriding default [gallery] once http://help.dimsemenov.com/kb/wordpress-royalslider-tutorials/wp-cr...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac