Update to HTTPS image still served over HTTP

Zac's Avatar

Zac

16 Jan, 2018 11:41 AM

Hi,

I've just updated a site to HTTPS, it's all serving correctly apart from the page with the Royal Slider slideshow on it, which is set via a shortcode.

When I view the slides in the back-end they're using HTTPS, but in the front end they're being served over HTTP.

Any tips how to update this? I'd assumed changing the protocol in the general settings would update this...

Cheers,

Zac

  1. Support Staff 1 Posted by Dmitry Semenov on 16 Jan, 2018 11:55 AM

    Dmitry Semenov's Avatar

    Hello,

    Slider uses default WP functions to retrieve image URLs, so generally, you shouldn't do anything to change to https.

    • Make sure that slider isn't cached (set cache refresh time to 0 on RoyalSlider settings page or re-save slider).
    • Make sure that site URL with https is set in WordPress General Settings as well is in wp-config.php
  2. 2 Posted by Zac Toff on 16 Jan, 2018 02:28 PM

    Zac Toff's Avatar

    Nice one, re-saving the slider did the trick.

    Thank you for the swift response :)

    Zac

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac