Occasional non load

shinx51's Avatar

shinx51

20 Jan, 2018 11:43 AM

Hi I have quite a few sliders on my Wordpress site however occasionally on some of the pages I notice the slider not loading. The loader icon whirs but will not load any images. If I go into the slider itself to edit it and only do a Save it fixes it. Any ideas how to prevent this?

  1. Support Staff 1 Posted by Dmitry Semenov on 20 Jan, 2018 05:15 PM

    Dmitry Semenov's Avatar

    Hello,

    How often does this happen? Can you please link to the page with the issue?

    Dmitry

  2. 2 Posted by shinx51 on 20 Jan, 2018 05:47 PM

    shinx51's Avatar

    Hi Dimitry thanks for the prompt reply. It is every now and then. Cannot say more there are over 260 pages of car profiles on the website each has a slider. Every now and then while updating I find one won't load.

  3. 3 Posted by shinx51 on 20 Jan, 2018 05:54 PM

    shinx51's Avatar

    This one is failing - http://www.sebeetles.com/may/

  4. Support Staff 4 Posted by Dmitry Semenov on 21 Jan, 2018 06:50 AM

    Dmitry Semenov's Avatar

    Next time this happens - right click on a page, click "Inspect', switch to "Console" tab and take a screenshot of it.

    I don't see any special configs on the page that you linked. Do you have a stable internet connection?

  5. 5 Posted by shinx51 on 21 Jan, 2018 08:55 AM

    shinx51's Avatar

    I will do that Dimitry. It's not only myself that has experienced it. I note that without me doing an Edit then Save on the May the page today has corrected itself.

  6. 6 Posted by shinx51 on 31 Jan, 2018 09:04 PM

    shinx51's Avatar

    Hi Dimitry error log attached.

  7. 7 Posted by shinx51 on 31 Jan, 2018 09:07 PM

    shinx51's Avatar

    Screenshot

  8. Support Staff 8 Posted by Dmitry Semenov on 01 Feb, 2018 07:02 AM

    Dmitry Semenov's Avatar

    Your issue is related to SSL (https). If you try to visit https version of your website (https://www.sebeetles.com) and get through all browser warnings you'll notice that all URLs point to https version. And if something caches "https" (secure) links - they won't work on "http" (unsecure site).

    A "simple" fix is just to disable slider cache (set cache refresh time on slider settings page to 0).

    A "good" fix is to setup SSL so all pages are https, or configure WordPress so it always works only with http (Site URL on its settings page, and URLs in wp-config) and redirects https:// to http://.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac