New Wordpress Version

will's Avatar


03 Dec, 2018 10:24 PM

Codecanyon just emailed about a new version, and I'm wondering if anyone has had any problems with the update before I install it? It looks like Gutenberg support is included, and not sure of any other changes.

  1. Support Staff 1 Posted by Dmitry Semenov on 03 Dec, 2018 10:50 PM

    Dmitry Semenov's Avatar


    Beta version of the release was tested, so there should not be issues. But if you'll notice some problem - please open a discussion with details.

    Only Gutenberg support was added, with a few optimizations and improvements. So this update is not mandatory if you don't use Gutenberg.

  2. 2 Posted by will on 03 Dec, 2018 11:07 PM

    will's Avatar

    Thank you Dmitry! Your support of this plugin is amazing.


  3. 3 Posted by Thomas on 07 Dec, 2018 09:33 PM

    Thomas's Avatar

    we really enjoy the slider on our page
    After updating to wordpress 5.0 our blog page went blank, just a white screen. Same for all blog posts. All other pages work perfectly. We checked the theme and disabled all plugins. It turns out that the royalslider plugin (Ver 3.3.8.) is causing the problem. I don't really understand why, since we use the slider on our startpage only.

    I got the following errors in the debug.log:

    [07-Dec-2018 09:30:43 UTC] PHP Fatal error: Uncaught Error: Call to undefined function gutenberg_parse_blocks() in /.../wp-content/plugins/new-royalslider/classes/NewRoyalSliderMain.php:213
    Stack trace:
    #0 .../wp-includes/class-wp-hook.php(286): NewRoyalSliderMain->find_and_register_scripts('')
    #1 .../wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #2 .../wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #3 .../wp-includes/script-loader.php(2231): do_action('wp_enqueue_scri...')
    #4 .../wp-includes/class-wp-hook.php(286): wp_enqueue_scripts('')
    #5 .../wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #6 .../wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #7 .../wp-content/plugins/new-royalslider/classes/NewRoyalSliderMain.php on line 213

    Do you have any idea what might be the problem?


  4. 4 Posted by contact on 08 Dec, 2018 12:48 AM

    contact's Avatar

    I have the exact same issue.
    So I tried to be smarted and installed the Gutenberg plugin. It's still not working.
    And now I have this message.
    Fatal error: Cannot declare class WP_Block_Parser_Block, because the name is already in use in /home/weddin45/public_html/wp-content/plugins/gutenberg/packages/block-serialization-default-parser/parser.php on line 10

  5. 5 Posted by contact on 08 Dec, 2018 05:30 AM

    contact's Avatar

    Actually it works with the Gutenberg Plugin!

  6. Support Staff 6 Posted by Dmitry Semenov on 08 Dec, 2018 06:45 AM

    Dmitry Semenov's Avatar

    The fix for WordPress 5.0 is up (v3.3.9)

    "Check Update" in the admin area or get the latest version from CodeCanyon and replace old files in FTP (in wp-content/plugins), CodeCanyon might be slightly delayed due to the review process.

    I apologize for the inconvenience.

  7. 7 Posted by Thomas on 08 Dec, 2018 10:14 AM

    Thomas's Avatar

    Everything seems to work fine now.
    Thanks for the fast help and great support!!

  8. 8 Posted by contact on 08 Dec, 2018 02:25 PM

    contact's Avatar

    So can we do without the Gutenber plugin ?

  9. 9 Posted by Thomas on 09 Dec, 2018 09:06 AM

    Thomas's Avatar

    We don't have the Gutenberg plugin installed and everything works fine.

  10. 10 Posted by passiamoltre on 11 Dec, 2018 03:36 PM

    passiamoltre's Avatar

    On my site, after updating Wordpress to 5.0 and RoyalSlider to 3.3.9, seems that RoyalSlider doesn’t load the js when required in the page.
    The only way to keep active the galleries is to force CSS and JS preload on every page through RoyalSlider settings.
    I’m the only one with this problem?

  11. Support Staff 11 Posted by Dmitry Semenov on 11 Dec, 2018 05:16 PM

    Dmitry Semenov's Avatar

    @passiamoltre, please elaborate - what method are you using to embed it. A simple shortcode text in post content area?

  12. 12 Posted by passiamoltre on 13 Dec, 2018 08:34 AM

    passiamoltre's Avatar

    I added it using the short code block.
    I tried saving again both the article and the gallery but nothing changed.
    An example page is this one
    I disabled the forced load option to let you see the problem.
    I tried the new Gutenberg block “RoyalSlider” in this page but nothing appears
    Thanks for help!

  13. Support Staff 13 Posted by Dmitry Semenov on 13 Dec, 2018 08:38 AM

    Dmitry Semenov's Avatar

    @passiamoltre, please open a new private discussion and provide temporary admin access

  14. 14 Posted by alan on 13 Dec, 2018 06:41 PM

    alan's Avatar

    I recently updated to version 3.3.9 and I am on version 4.9.9 of wordpress. I have not installed Wordpress 5. When going to the website I get the following error:
    Fatal error: Call to undefined function register_block_type() in /data/18/1/139/27/1628027/user/1754854/htdocs/wordpress/wp-content/plugins/new-royalslider/gutenberg/gutenberg.php on line 23
    I have the site running but had to deactivate Royal Slider.
    Thanks for your help.

  15. Support Staff 15 Posted by Dmitry Semenov on 13 Dec, 2018 08:09 PM

    Dmitry Semenov's Avatar

    @alan, try to temporarily deactivate other plugins and switch to default theme and check if it helps. Also, consider updating to the latest version of WordPress, even if you're not using Gutenberg - you may install classic editor plugin.

  16. 16 Posted by kris on 15 Jan, 2019 02:55 PM

    kris's Avatar


    I am looking for help in regards Royal Slider plugin on my web page please. WP is up to date, as everything else but overtime I activate Royal Slider it blocks my webpage, and theres only one message popping up:
    Fatal error: Call to undefined function gutenberg_parse_blocks() in /homepages/15/d592249929/htdocs/PhotoImaginarium/wp-content/plugins/new-royalslider/classes/NewRoyalSliderMain.php on line 213

    Any advice of how to fix this please.

    Thank You!

  17. Support Staff 17 Posted by Dmitry Semenov on 15 Jan, 2019 03:01 PM

    Dmitry Semenov's Avatar

    @kris, Hello, what version are you using? You can view it on your plugins page. Make sure that you're using 3.3.9+

  18. 18 Posted by Kristina Imagin... on 15 Jan, 2019 03:08 PM

    Kristina Imaginarium's Avatar

    Hello Dmitry,

    Thank you for your prompt reply and your help! It worked.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac