Slider completely stopped working

dmartini's Avatar

dmartini

25 Jan, 2019 04:01 PM

Use to have royal slider running slideshows on these photo gallery project pages. At some point in the last couple weeks they stopped working completely. I'm not entirely sure why. It seems like it's not getting any JS? The HTML and CSS are there in the source code but it's not displaying or running properly. The images are being loaded.

The slider use to be displayed right above the description box, and beneath the "back to search results" and "project: XXX" headings/button looking things.

Link: <DELETED> *deleted link because I fixed it :)

This isn't integrated via short code. I'm a developer coming in on an existing project. I'm not entirely sure how it's set up. There is a template file dedicated to generating the HTML.

If anyone could take a look a provide some input I'd really appreciate it. Banging my head against the wall on this one.

  1. 1 Posted by dmartini on 25 Jan, 2019 04:08 PM

    dmartini's Avatar

    I should add -- I've been troubleshooting on a staging branch, so anything I've tried wont reflect on the page I've linked. I've disabled all caching plugins, most other plugins, etc. in an attempt to fix my issues.

  2. 2 Posted by dmartini on 25 Jan, 2019 04:25 PM

    dmartini's Avatar
    <script>
        jQuery(document).ready(function($) {
            $(".royalSlider").royalSlider({
                // options go here
                // as an example, enable keyboard arrows nav
                keyboardNavEnabled: true
            });  
        });
    </script>
    

    Including this code seemed to fix it. I'm not sure why it wasn't loading the JS. I have the settings configured properly.

  3. Support Staff 3 Posted by Dmitry Semenov on 25 Jan, 2019 05:17 PM

    Dmitry Semenov's Avatar

    Hello,

    If you're using WP version, the code from your last message is often a wrong way to fix the issue. With this code, slider won't use options that were defined in admin area.

    To include slider JS/CSS files try this option - http://help.dimsemenov.com/kb/wordpress-royalslider-tutorials/wp-in...

    If it won't help refer to this guide http://help.dimsemenov.com/kb/wordpress-royalslider-faq/wp-slider-l...

  4. 4 Posted by dmartini on 25 Jan, 2019 05:25 PM

    dmartini's Avatar

    Go to RoyalSlider -> Settings and check "On every page" option in "Preload CSS and JavaScript files" section.

    This setting is ticked and has been ticked. I'm not sure what prevented the JS from loading out of nowhere. I don't see any JS errors on the page and I do not believe it is being loaded twice.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac