Responsive issues

a-aadam's Avatar


25 Jun, 2019 04:18 AM

Hi. I just took over a site using the plugin and starting to troubleshoot some mobile issues before launch.
Site is
Issue 1: I have a 3 cm gap between button and next section on front page gallery.
Issue 2: I have near full screen gap between image and thumbnails in 5 galleries.
Can this be eliminated in plugin settings or only using css?
Hope you can help me.

  1. Support Staff 1 Posted by Dmitry Semenov on 25 Jun, 2019 01:29 PM

    Dmitry Semenov's Avatar


    You have styles that force height to the slider in file , for example:

    .rsOverflow, .royalSlider.rsContentSlider {
        width: 100%!important;
        height: 600px!important;

    Since you're using auto-height option the size is measured based on the height of the content, rather than the root element. You also should avoid applying size directly to .rsOverflow element).

  2. 2 Posted by a-aadam on 26 Jun, 2019 08:37 AM

    a-aadam's Avatar

    Thanks for the swift reply. Since I have no prior knowledge of your plugin and the original developer is on summer vacation, I am left with sorting this problem, and I am at a loss here. How should I solve this?

  3. Support Staff 3 Posted by Dmitry Semenov on 26 Jun, 2019 02:53 PM

    Dmitry Semenov's Avatar

    The styles come from minified and combined CSS file, and I do not know your website architecture.

    So I have no idea where these styles are defined.

    What I can tell for sure is that they're not coming from the slider plugin files or its options.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • royal-slider-issues.jpg 72.2 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac