deprecated constructor

dsanchez6407's Avatar

dsanchez6407

08 Feb, 2020 07:24 PM

Everything seems to be up to date. I have 3.2.0 installed and it says up to date but I'm getting this:

he same name as their class will not be constructors in a future version of PHP; NewRoyalSliderWidget has a deprecated constructor in /hermes/bosnacweb05/bosnacweb05cb/b1777/ipg.highendspecialistsco/backup_miamiemergencyplumbing/new_backup/wp-content/plugins/new-royalslider/classes/Widget.php on line 13

any help to resolve this would be appreciated.

thank you

  1. Support Staff 1 Posted by Dmitry Semenov on 09 Feb, 2020 05:58 AM

    Dmitry Semenov's Avatar

    Hello,

    It seems you're using old version that didn't have auto-update enabled, you'll need to update the plugin manually (manual update instructions are on top of the changelog here https://dimsemenov.com/plugins/royal-slider/wp-update/ ).

    Dmitry

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac