Images not displaying in Royal Slider

Mohsin's Avatar

Mohsin

01 Sep, 2020 06:35 PM

Can you please check this link and let me know why is the slider not loading the images on the front-end?

https://ariabuildconstruction.com/codeless_portfolio/home-extensions/

Thanks

  1. Support Staff 1 Posted by Dmitry Semenov on 02 Sep, 2020 07:11 AM

    Dmitry Semenov's Avatar

    Hello,

    You have a few JS errors from another plugin or theme that block the execution.

    likely related to this https://motopress.com/blog/wordpress-5-5-fix-jquery-migrate-helper/

  2. 2 Posted by Mohsin Hussain on 03 Sep, 2020 05:55 AM

    Mohsin Hussain's Avatar

    Hi Dmitry Semenov,

    Many thanks for your email and technical support. Now, I am able to see the
    images but not thumbnails.

    Thanks again.

    Kind regards,
    Mohsin

  3. 3 Posted by nm on 17 Sep, 2020 09:38 AM

    nm's Avatar

    Hi Dmitry,
    I have the same issue after updating to WP 5.5.
    I tried two possible shot codes:
    1. You recommend on the edit slider page
    wp-admin/admin.php?page=new_royalslider&action=edit&id=1&rstype=nextgen
    [ngg_images gallery_ids="1" display_type="ds-nextgen_royalslider"]
    In this case you can see the big images only.

    2. Atomatically inserted by „add gallery“
    [ngg src="galleries" ids="1" display="ds-nextgen_royalslider"]
    You can see thumbs and links to the big images.

    Any trials with up- and downgrades of the Wordpress, plugins, themes, installation of Enable jQuery Migrate Helper and so on gave no results. Do you have any idea, how to fix this issue?

    Here a sample page:
    https://www.mashyan.com/tmp/

    Best regards,
    Natasha

  4. Support Staff 4 Posted by Dmitry Semenov on 17 Sep, 2020 04:46 PM

    Dmitry Semenov's Avatar

    Hello @Natasha,

    Files don't seem to be included, go to RoyalSlider Settings page and check an option to include files on every page.

    Let me know if it won't help.

  5. 5 Posted by nm on 18 Sep, 2020 05:58 AM

    nm's Avatar

    Unfortunately not. Now all images are hidden.

  6. Support Staff 6 Posted by Dmitry Semenov on 18 Sep, 2020 04:52 PM

    Dmitry Semenov's Avatar

    Possibly, you're using some kind of plugin that changes/modifies/optimizes performance? Something changes the order of scripts.

    Try to temporarily deactivate other plugins and switch to the default theme, to see which is causing the problem.

  7. 7 Posted by nm on 19 Sep, 2020 10:42 AM

    nm's Avatar

    I have not any plugin that modifies performance, only backend stuff (like classic editor). Standard theme shows the black screen too.

  8. Support Staff 8 Posted by Dmitry Semenov on 19 Sep, 2020 07:24 PM

    Dmitry Semenov's Avatar

    Are you having the same issue with the default WordPress [gallery] shortcode as well? Or this issue happens just with nextgen?

    Please also make sure that you're using the latest version of it. You can also try adding something like this to your functions.php:

    function rs_add_jquery () {
      wp_enqueue_script('jquery');
    }
    add_filter('wp_enqueue_scripts', 'rs_add_jquery');
    

    It'll make sure that jQuery is included.

  9. 9 Posted by nm on 20 Sep, 2020 08:26 AM

    nm's Avatar

    Wordpress gallery is working properly. I’ve reinstalled nexgen again and added the code to my functions.php
    Everything done, but nothing works…

  10. Support Staff 10 Posted by Dmitry Semenov on 20 Sep, 2020 11:54 AM

    Dmitry Semenov's Avatar

    Please open a separate private discussion and provide a temporary admin access, and I'll check what might be wrong (or email me directly, you can find it here https://dimsemenov.com/).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac