Images not displayed in widget, captions appear as list

roger's Avatar

roger

16 Nov, 2020 03:56 PM

Hi,

I have a strange occurrence that appeared after a recent update (but I don't know which): the gallery in the Royalslider widget doesn't show any images, only the captions as a list.

The galleries in posts and pages work fine. Better, if there is already a Royalslider gallery in a page or post, then the widget works just fine.

I suppose this is a javascript loading error, but I have no idea how to fix it. I saw another topic that could be related and installed the Enable jQuery Migrate Helper plugin, but it doesn't change anything.

Thanks for your help.

RP

  1. Support Staff 1 Posted by Dmitry Semenov on 16 Nov, 2020 05:54 PM

    Dmitry Semenov's Avatar

    Hello,

    I'd need a link to the page with the issue.

    To debug yourself, please refer to: http://help.dimsemenov.com/kb/wordpress-royalslider-faq/wp-slider-l...

  2. 2 Posted by roger on 17 Nov, 2020 09:58 AM

    roger's Avatar

    Hi,

    Thanks for the quick reply.

    I solved the problem myself by looking at your link, and checking the box “Preload CSS and JavaScript files -> On every page”

    For some reason some other process was loading javascript before, and it stopped. I had already checked the “On posts with slider shortcode…” box, so it was working on all my gallery posts and pages but apparently this doesn’t take into account the widget when it’s on a page by itself.

    Best,
    RP

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac