Unable to automatically resize images (responsive)

mucube2's Avatar


07 Sep, 2012 12:06 PM


something i missing and i'm unable to make images working when i resize the browser window. I read the documentation, i show the templates and the code of each one, but i can't.

if you can help, i'll appreciate cause i lost on this 4-5 hours on this.


  1. Support Staff 1 Posted by Dmitry Semenov on 07 Sep, 2012 03:29 PM

    Dmitry Semenov's Avatar


    Set CSS width of slider to 100% and enable autoScaleSlider option. That's all.


  2. 2 Posted by ben on 04 Oct, 2012 07:08 PM

    ben's Avatar

    Im having a similar problem. Slider is set to 100% and autoScaleSlider is enabled and the image doesnt scale. My image gets cropped with the nav buttons left at their original position. And when scaling the image continues to get cropped and not scaled down.
    Ive attached the images.

  3. Support Staff 3 Posted by Dmitry Semenov on 05 Oct, 2012 07:28 PM

    Dmitry Semenov's Avatar


    Please send me a link and I'll take a look what's wrong. Make sure that imageScaleMode is set and your site doesn't apply any CSS properties to img.


  4. 4 Posted by ben on 11 Oct, 2012 10:20 AM

    ben's Avatar

    Hello Dmitry,
    Heres the link: www.erinelsie.com
    Sorry for the delay..
    Any help would be great.

  5. Support Staff 5 Posted by Dmitry Semenov on 11 Oct, 2012 12:06 PM

    Dmitry Semenov's Avatar
    1. imageScaleMode can be "fill", "fit-if-smaller", "fit" or "none". It can't be true. http://dimsemenov.com/plugins/royal-slider/documentation/#options

    2. You may not combine unminified and minified version of scripts as some private variables are renamed.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac