RoyalSlider Autoplay Not Functionting

jeremyccrane's Avatar


01 Oct, 2012 08:25 PM

I have setup Royalslider to replace a different javascript plugin (current live slider viewable at but I am having issues with the slider auto-playing and fading. For some reason, the code does not engage.

Here is my images code:

<div id="loading"></div>
<div id="rslider-wrapper">
    <div id="rslider" class="royalslider">
         <div class="background-one"></div>
         <div class="background-two"></div>
         <div class="background-three"></div>
         <div class="background-four"></div>
         <div class="background-five"></div>
         <div class="background-six"></div>

I have each of the inner div's setup to have a background image (for scaling & proper cross-browser full screen images).

Here is my royalslider code:

<script type="text/javascript">
jQuery(document).ready(function($) {
                    arrowsNav: true,
                    //slidesOrientation: 'horizontal',
                    transitionSpeed: 450,
                    allowCSS3OnWebkit:  true,
                    loop: true,
                    keyboardNavEnabled: false,
                    //controlsInside: true,
                    //imageScaleMode: 'fill',
                    arrowsNavAutoHide: false,
                    autoHeight: false,
                    autoScaleSlider: false,
                    controlNavigation: 'bullets',
                    thumbsFitInViewport: false,
                    navigateByClick: false,
                    slidesSpacing: 0,
                    startSlideId: 0,
                    autoPlay: {
                        enabled: true,
                        delay: 400
                    //globalCaption: true,
                    controlsinside: true

Here is a link to the test page:

Thanks for the help!!!!

  1. Support Staff 1 Posted by Dmitry Semenov on 02 Oct, 2012 10:58 AM

    Dmitry Semenov's Avatar


    You've got a few errors from your app.js script, fix them first, they might block javascript execution.


  2. 2 Posted by jeremyccrane on 02 Oct, 2012 06:54 PM

    jeremyccrane's Avatar

    Thanks Dmitry!

    I actually removed all scripts from the page except for Royalslider, cleared my cache, and still no response.

    Would you mind looking at it again??


  3. Support Staff 3 Posted by Dmitry Semenov on 03 Oct, 2012 05:56 AM

    Dmitry Semenov's Avatar

    Also, autoPlay module is missing, you included only core of slider. Please don't forget to include it when getting js from buld tool -


  4. 4 Posted by daleleung on 13 Oct, 2012 07:56 PM

    daleleung's Avatar

    Yeah, I fixed the same issue too after reading this post - by including Autoplay's scripts. Had been searching high and low I assumed that Autoplay is already inside the script.

    Anyway, thank you for the R.slider and I enjoyed it! I'd since incorporated it into my custom WP engine so that I'll just need to load pictures into post, define a custom category and slide away. Great job!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac